American Sedan Forum

American Sedan Forum (http://s91730302.onlinehome.us/forums/index.php)
-   American Sedan Pics and Videos (http://s91730302.onlinehome.us/forums/forumdisplay.php?f=25)
-   -   June Sprints Saturday (http://s91730302.onlinehome.us/forums/showthread.php?t=3445)

racindavid1 06-24-2014 07:38 PM

June Sprints Saturday
 
https://www.youtube.com/watch?v=uskHGO3k03I

Good racing action with Chris Pederson. :duel: Note Scott's rocket ship Cadillac at the start ! :auto: No lack of power there !!
I finally had a car that would stop, but it takes a while for the confidence to come back, especially at RA ! Chris would pass me under braking into 8, and I would get it all back in the carousel and kink. You can also see his car was laying down big time at the end of the straights. Felice power in mine is 14 events old, with nothing but a valve spring change. Car was shifting badly throughout the session, got progressively worse and right after this clip ends the :censored: clutch goes... So much for a podium ! :(
Enjoy.
Venhaus

atimmons 06-25-2014 09:06 PM

question
 
David
I am curious about the clutch failure. Was it the throw-out bearing that failed or the friction surface that decided to depart?
Watching the video, I noticed that you left foot spent an awful lot of time on the clutch pedal. At times, the clutch pedal is depressed noticeably.
I don't know how "tight" your clutch is set up, but knowing how hydraulic systems are, it is possible that you might have been marginally disengaging the clutch.

Just an observation, I am definitly not trying to say anything more than that.

Thanks for posting the video. Very good camera position to see the track, the driver movement, and the car movement.

Andrew

racindavid1 06-26-2014 11:49 AM

The clutch material departed the disk on one side.
The car definitely needs a dead pedal (amongst other things, like new wiring, etc)
The clutch was fully engaged about 1/3 of the way up from the floor. I was very conscious of putting my foot on it while driving... The first inch or so of pedal travel took ounces of force, so I highly doubt I was generating any pressure in the system, but still, a dead pedal in in order. It was a RAM HD clutch with organic material on both sides. It was 4 events old. Flywheel looked fine. I took some emery to it for good measure, threw a new motorsport PP and RAM sintered disk in and ran again Sunday. A driveline vibration loosened the shifter linkage and we DNF'd again... :banghead: I think it's the Quartermaster driveshaft, which I've had vibration problems with from day 1. Chris was nice enough to let me throw the car up on the lift in his trailer which made the change pretty easy. Both days were a blast though as we had people to race with for both events. I was just happy the car finally stops ! Up till now my tow vehicle stopped better !

kbsmith1 06-26-2014 11:58 AM

Nice video. Your car sounds great.

racindavid1 06-26-2014 04:22 PM

Thanks ! Felice power ! Ken knows how to build 'em !


All times are GMT -4. The time now is 05:35 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.