PDA

View Full Version : Portland Double National Results


kbsmith1
07-07-2009, 01:37 PM
It was pretty hot for Portland. mid-high 90s both friday & saturday,
mid 80's sunday. These were non-chicane races. It has been a while
since nationals have been run without the chicane here.

Practice Friday morning
John Blizzard -1:18.4
Kevin Smith - 1:19.5
Tim Jorgensen - 1:25.2

Qual Friday afternoon
Blizzard - 1:18.8
Smith - 1:19.9
Jorgensen - 1:23.1

Race Sat afternoon
1st Blizzard - 1:19.9
2nd Jorgensen - 1:24.0
DNF Smith - 1:23.9

Blizzard's car was in big wreck Sat morning in GT1 race, and his crew
really did an amazing job to get the car on grid for the AS race.
In the first race I only did 1 lap. I was chasing Blizzard pretty close with a
couple of EP RX7s fighting between us/behind us at various points on the
track as their tires warmed up. I took a big off in Turn 4, after braking just
a bit too late, and lost the fan belt. It overheated as soon as I got it back
on track, so I pulled it in. Blizzard cruised to the win, and Tim J cruised
to a 2nd. Not much racing going on in AS.

I had to find new fan belt and alternator on Sat July 4 to be ready
for Sun morn qual. In the off, the alternator fan broke apart at the same
time the belt came off. I lucked into finding a NAPA open until 4 PM
at 3:45, got my parts, and got the thing ready for Sunday.

Sunday morning qual
Smith - 1:19.6
Blizzard - 1:19.9
Jorgensen - 1:22.9

Sunday afternoon race
1st - Blizzard - 1:18.7
2nd - Jorgensen - 1:21.8
DNF - Smith - 1:20.5

I was on the pole for this race, and led the first 2 laps, trying to keep an
EP RX7 between Blizzard and I. Blizzard passed me on 3rd lap just past
start finish, he has some HP on me it seems. I was keeping up/catching
up a bit in the west-end corners, but he was stretching out the lead on
the big straights. On lap 5 my engine blew up big on the back-straight
just before the braking zone for turn 10. I took an interesting ride
straight off the outside of 10 as oil and water soaked my tires and
brakes. Drove in the grass for a bit and coasted into the pit lane, DOA,
oil and water all over, including dripping on my feet, probably blew in the
vent? Blizzard cruised to win. Jorgensen just wanted finishes and cruised
around to get 2nd. Once he had his 12 laps in he picked up his pace a bit
to get his fastest laps of the weekend.

That's the report.

Don't know what happened to the engine yet, but I can see dents
in the oil pan where parts tried to get out. I haven't seen any huge
holes yet to know where oil and water got out.

Tim White
07-07-2009, 02:04 PM
Tough weekend. Just when you think you have some luck with finding the parts you needed it all goes south. How many hours did you have on this engine?

kbsmith1
07-08-2009, 02:33 AM
I just freshened it this winter, and it has only been in five races this
year, counting the two described in this report.
It was a good fast engine that had been working quite reliably.
Iron head 305 chevy, but with lots of good parts.

Here's links to some pics of the damage. Engine isn't out of the car
yet, so I don't know what is still usable, but it looks bleak.

http://i215.photobucket.com/albums/cc250/kbsmith1_photo/IMGP1760.jpg
http://i215.photobucket.com/albums/cc250/kbsmith1_photo/IMGP1762.jpg
http://i215.photobucket.com/albums/cc250/kbsmith1_photo/IMGP1766.jpg
http://i215.photobucket.com/albums/cc250/kbsmith1_photo/IMGP1765.jpg
http://i215.photobucket.com/albums/cc250/kbsmith1_photo/IMGP1767.jpg

King Matt
07-08-2009, 01:28 PM
Can't say as I've even seen the bottom of a timing chain cover blown out like that. Since the crank snout appears to be still attached to the rest of the crank, I wonder if the upper sprocket snapped off?

jimwheeler
07-08-2009, 02:32 PM
Cam failure?

kbsmith1
07-08-2009, 03:05 PM
Don't know failure yet.

I've seen a similar can opener effect with timing chain a long time
ago. Interestingly failure happened in 2000 in virtually same place
on track. In that case, timing chain broke (it was stock style, not
double roller), and then the crank pulley keeps pulling it around, it
bunches up on passenger side of timing cover and then the crank
sprocket keeps pushing chain through, and the cover gets pried
open. When that happenned in 2000 it bent lots of valves, but
otherwise the bottom end was OK, except for needing timing chain
& cover to be replaced.

socalta
07-08-2009, 04:13 PM
bummer Kevin.. sorry to see that happen..
Hope you get her back running ..:thumbsup:

bmvco
07-09-2009, 12:22 AM
Did you have any wheel hop before this happened? My car did the same thing last year and I think wheel hop had something to do w/ the bottom gear breaking.

kbsmith1
07-09-2009, 10:33 PM
Don't think wheel hop contributed. But I can't say the car never
wheel hops.